Sauce Labs Customer Idea Portal

Submit an idea and make Sauce Labs even better!

Ability to run scripts in Latest Platform version by providing platform as windows/Mac and not explicitly providing version

This option works very well for browsers so when we setCapability("version") = latest the latest browser version is picked; however this provision is not applicable for Platform in both Mobile and Web and would be a wonderful option

For now when I give PlatformName as "windows" and do not provide platformversion it defaults to Windows 7 and not 10

In Mac when I dont give Platform version it takes Mac 10.13 and not Mac 10.15

I was wishing we had a way to by pass this and have scripts run in latest platform when no version is provided or when "latest" is provided

  • Krishnapriya Lathika
  • Oct 12 2020
  • Needs review
  • Attach files