Sauce Labs Customer Idea Portal

Submit an idea and make Sauce Labs even better!

Support glibc 2.12 in SC 4.4.0 and up

Red Hat Enterprise Linux 6 (and CentOS 6) use glibc 2.12, but Sauce Connect requires glibc 2.14 as of 4.4.0.  Idea is to add support for RHEL 6 (and CentOS 6), as these are popular platforms in enterprise environments that will be supported by Red Hat through at least 2021.

 

An alternative would be maintaining a legacy branch based on 4.3.16, which does not have the glibc 2.12 dependency.

  • Daniel W
  • Sep 19 2016
  • Shipped
  • Attach files
  • Daniel W commented
    10 Mar, 2017 06:03pm

    4.4.4 (which adds glibc 2.12 support) is working on RHEL 6.  Thank you!